じゅにゃくんのはてブロ。

ブログ不精なんですが...。

gem置き場が落ちててvagrant plugin installがコケるときの対処

tokyo-m.rubygems.orgが落ちているようで vagrant plugin install がコケてしまっている。
この場合の対処方法。

$ vagrant plugin install sahara --plugin-source http://production.s3.rubygems.org

こんなふうに plugin install に --plugin-source オプションをつけて、動いているgem置き場を指定してやると良いようだ。

bundle などで gem をインストールしている場合は
tokyo-m.rubygems.org が落ちていて rubygems がインストールできない。
が参考になる。

Ruby で何かやるたびに一つ一つ引っかかる自分は Ruby とは相思相愛になれそうにないよ…。

広告を非表示にする